X Ads - Missing data since 26 March

Incident Report for Funnel

Update

We have made progress in our investigation into the data issues affecting X Ads sources.
We have identified two separate issues contributing to the disruption, both not only limited to Funnel but confirmed across the broader X Ads API ecosystem:

Intermittent errors when retrieving campaign data. This caused some downloads to fail entirely. Based on our monitoring, this issue has largely subsided.

Incomplete or missing metrics for certain ad configurations, some X Ads sources are returning incomplete data for metrics such as impressions, clicks, and cost. This issue appears to still be ongoing and is not limited to Funnel.

We are continuing to monitor both issues closely. Sources affected by the first issue has successfully been resolved.
For the second issue, we are tracking the situation and will trigger re-syncs once complete data is available.

We understand this impacts your reporting and continue to treat this with the highest priority.
Posted Apr 03, 2026 - 17:02 CEST

Investigating

We're aware of an issue where some customers are not seeing data after 2026-03-26 for their X Ads sources. We're currently investigating the cause.
Posted Apr 01, 2026 - 11:41 CEST